Suggested change to the UCMD extension

Ideas for ADC may be presented here for others to review and point out flaws or further improve the idea.
Forum rules
If you have an account on the wiki, remember to update the ADC Proposals page for new ideas.
Senior Member
Posts: 100
Joined: 30 Dec 2008, 14:59

Suggested change to the UCMD extension

Post by darkKlor » 16 Oct 2009, 22:09

The current state of the UCMD extension ( bothers me with its lack of user-friendly command names. Seeing a list of menu items beginning with a + is not going to win any GUI design awards, and you have the unusual situation where the hub is actually inflicting an ugly GUI upon the client!

Another potential issue I see in the spec is the way you specify a 'logical structure' to commands for submenus. This does not appear to allow a menu item which only contains subitems, rather than being an actual command. Therefore, I suggest adding an additional required parameter to UCMD ('name' becomes 'command', the new 'name' is the user-friendly name).

CMD command name
A forward slash (/) indicates the menu level. One slash is a top-level menu item, two slashes indicates a sub-item of the last top-level menu item. A slash followed by no command name indicates the item is only for user-interface display and has no hub command attached to it (e.g. in the following example, Administration is a top-level menu item with three sub-item commands).
CMD / Administration CT3
CMD //+ban Ban TTHMSG\s+ban\\syada CT1
CMD //+kick Kick\sUser TTHHMSG\s+kick\\syada CT2
CMD //+listbans List\sBans CT3

This would produce the following menu:
---- Ban
---- Kick User
---- List Bans

Note that the structure determination via the forward slash relies on the previous CMD message received being known. It may help the client implementor if a flag is required to indicate the last menu item at every level of every branch of the menu tree.

Another grievance, the format specifiers for strftime should be included in the spec, and classed as reserved keywords, rather than the hub being able to override them. It just makes life more consistant if anybody reading code knows that a %A is going to turn into a 'full weekday name' rather than there being the potential for it to become something else.

Posts: 56
Joined: 17 Aug 2009, 21:32

Re: Suggested change to the UCMD extension

Post by Quicksilver » 24 Feb 2010, 14:00

probably this is way old and no longer of interest..

that + in commands is all fault of hubadmins...
there is nothign that hinders you from making some more userfriendly command name in there.. just send a god damn \s and you have a space.. or what ever..

on Submenu also being a command.... thats problematic IIRC not supported by all OS ...
with hierarchie there is no need for any menu structure remembering ... that was so damn ugly in NMDC (seperators lacking hierarchie information) and we should not going back to that..